メインコンテンツにスキップ

Why will my roller not stay on?

The rug cleaner roller will come on but will not stay on for more than 30 seconds. The roller is clean, the belt is fine. The switch seems to be working. What could my problem be?

回答がありました! 回答を表示 同じ問題があります

この質問は役に立ちましたか?

スコア 0
コメントを追加

6件の回答

ベストアンサー

Hi P. Taylor! The first thing that I would think to check would be the motor and if that is actually powering the belt. The next thing I would check would be to see if the belt is tight enough to consistently activate the roller as it may look good, but could be stretched.

このアンサーは役に立ちましたか?

スコア 0

7 件のコメント:

The motor to the roller actually shuts down but the vacuum motor stays strong. How would I differentiate between the vacuum motor and the motor running the roller, is there some trick?. It runs fine for 30 seconds then stops. The belt was changed so this is not the issue. Thank you for your answer.

さんによる

Thanks, that video is elementary not my problem. If I bypass the circuit board in the vacuum head it will run and maintain running. Other than activating the roller switch is there anything else I should know that this circuit board does?

さんによる

Did you ever get it fixed? This is the exact same problem I’m having

さんによる

I have the exact same problem as well. Roller comes in for. Few seconds and then stops.

さんによる

Well what was the issue??

さんによる

2件以上のコメントを表示

コメントを追加
最も参考になった回答

I think my air pro developed this problem. The roller is supposed to automatically engage when you recline the vacuum. My vacuum will only engage the brushroller if I recline the vacuum barely an inch or two, any lower and it instantly shuts off. It was almost impossible to vacuum in this weird upright position so I’m looking for a fix. I feel like the problem is somewhere low around the steerable neck area, like a sensor is giving a false reading. If i find an answer i’ll let you know.

このアンサーは役に立ちましたか?

スコア 1

2 件のコメント:

I am having the same problem

さんによる

I’m having the same problem but if I shut mine off and when you turn it back on then it works again for about 30 seconds and it just keeps doing the same thing

さんによる

コメントを追加

I have the same problem. I disassembled the housing for the brush and started the vacuum to see if the motor would run and stay running with the belt disconnected, same result. The motor runs for a few seconds then stops. I replaced the motor, same result. There is a small circuit board that the motor plugs into (they call it a wiring harness). I will replace this board and retry. My thought is that maybe a capacitor or transistor is going bad on this board causing the motor to stop running.

このアンサーは役に立ちましたか?

スコア 1

1件のコメント:

Could it be the mechanical switch which turns the roller off when the unit is parked?

さんによる

コメントを追加

I purchased belt, part number listed in Manual and replaced belt but it is too long and will not run the roller. Anyone else have this problem?

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

This thing is stupid by a new vacuum on wayfair

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

I’m having the same problem - since its last service actually, when they replaced/upgraded parts. Spend more time cleaning it than using it effectively. Ready to throw it away now.

It is worse on carpet than tiles, but does it there too.

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

回答を追加する

P. Taylor さん、ありがとうございました!
統計データ:

過去 24時間: 1

過去 7 日: 13

過去 30 日: 56

今までの合計 6,309