メインコンテンツにスキップ

2016年9月16日に発売。モデル番号は1660, 1778で GSM かCDMA があり。/ 32、128、 256 GB / 色はローズゴールド、ゴールド、シルバー、ブラック、ジェットブラック

2027回答 すべてを表示

iPhone 7 Boot Loop issue with Front Camera/Proximity sensor/Ear Piece Flex

I have an iphone 7 that is stuck in a bootloop after screen replacement. Ive narrowed it down to the proximity/front camera/earpiece flex. When its disconnected phone powers up fine but when reconnected goes straight back into bootloop again. Have tried replacing flex cable twice with no luck so figure its a mainboard issue?

回答がありました! 回答を表示 同じ問題があります

この質問は役に立ちましたか?

スコア 7

コメント:

This is an issue that seems to exist quite frequently. I personally don't know how to fix it but maybe @danj or @mayer could give it a shot. Sorry I couldn't help more.

さんによる

Thanks for the comment mate, hopefully will hear back from the guys you have tagged...

さんによる

You bet you will

さんによる

Sorry guys I'm not a iPhone hardware guru. Maybe Minho @refectio or Rany @rany can give you an answer.

さんによる

@danj Sorry to bother you! I figured you'd know.

さんによる

5件以上のコメントを表示

コメントを追加

9件の回答

選択されたソリューション

Ideally, you have to try a known-good FCAM flex. Small parts can be hit or miss, especially for something as new as an iPhone 7. If you don't have access to a known-good part, then the logic board needs to be verified to try and eliminate something.

What's probably happening is that one of those elements (CAM/PROX/ALS) of the circuit is defective. Once the flex is connected, it may be drawing too much current and forcing the some other power rails into current limiting mode. This will have to be looked at by a micro-solderer.

このアンサーは役に立ちましたか?

スコア 6

コメント:

I had same issue. I believe that they key to resolving issue is to make sure that the front facing camera flex cable isn’t folded or bent incorrectly. I adjusted the flex cable to proper positioning and issue went away.

さんによる

Same issue, just tested and can confirm that it’s the home button. Not sure why. Gotta sacrifice one lol. Good luck

さんによる

コメントを追加

I would try a complete assembly from a working phone, if available. In other words, try with a known good complete assembly. Sometimes new ones are bad too like mentioned by others here.

Also make sure you are connecting it in the correct orientation.

Finally, connect the front cam assembly without plugging the home button extension cable onto the board, see if that changes anything.

Only if using a known good assembly in the correct orientation yields the same result, can you then conclude that you have a board level problem.

Note: continuous boot looping may cause data corruption. Pull a back-up before testing any further.

このアンサーは役に立ちましたか?

スコア 5

コメント:

I have same problem, after desconnected homebutton front facing camera work and phone boot. What have front facing camera flex and homebutton conjucted?

さんによる

Probably a data line. Haven't had time to check the schematics.

You can try a different screen just to make sure the issue is not due to the Home Button extension cable built into the replacement screen.

さんによる

it was the home button cable . i try disconect it and try and boot lop gone!!.

さんによる

I had the same issue, customer dropped her phone and the home button stopped working, Turned out the button cable had torn. I replaced the screen and it was constantly boot looping, booted fine without the front flex attached. Saw the comment on here to disconnect the home button and it worked absolutely fine. Customer knew the home button would no longer work so I just snipped off the home button connector and put it back together.

さんによる

コメントを追加

Just in case anyone finds this question and possibly did the same thing as me, check to make sure you’re putting the cable the right way…. I tried putting it in upside down because I wasn’t following the guide as I thought I knew what I was doing… Found that out after I bought a new sensor/camera cable.

このアンサーは役に立ちましたか?

スコア 2

コメント:

Fixed many iphone's over the years and never thought that i would do the same thing and be placing the cable for the front camera the wrong way around. %#*@ i feel stupid :D Thank you so much

さんによる

Ok been scratching my head for awhile. 100% true. Guess it’s some sort of safety feature. Ya make sure you have the flex cable in the right way!! Boom should work ??

さんによる

コメントを追加

I had issues with sensorflex as well, first replacement resulted in bootloop, second replacement, no speaker, no proximity

I just fixed these two sensorflex by re-soldering the contacts under the sticker, the factory soldering was bad, even on the flex that I pulled from the original phone

Block Image

Also the proximity frame on the new display “OEM quality” did not align with the sensor “eyes”

Block Image

このアンサーは役に立ちましたか?

スコア 1
コメントを追加

Not sure if solved yet, but I had this exact issue, phone will bootloop, but when sensor flex is disconnected it will boot up fine. Strangely enough this was due to a small tear in the flex cable that connects the home button to the board. And when this cable is disconnected the phone boots fine even with sensor flex connected.

Hope this helps

このアンサーは役に立ちましたか?

スコア 1
コメントを追加

I had struggled with this problem but found a different issue that solved my troubles, there is a screw that sits above the front camera housing on the screen. See yellow circle in the attached image. This was missing in the new screen. once replaced the phone booted up straight away.

Block Image

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

I had the same problem, client came in the shop with iphone 7, he tried to replace the display but broke the homebuttonflex. Try to boot without the homebuttonflex attached!

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

me facing this same issue on iphone 7 , its very clean PCB , when connect front cam senser cable its gone bootloop, if disconnected the phone will boot up normaly , i already changed the senser cable both(ORIGINAL and COPY), i dont understand exactly what will be the right issue , also i found there is no any short cercuit in normal mode, let me check it well ,

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

I had the same issue… phone would boot only when I had either the Front Facing Camera Flex Removed or the Home Button Removed… a new screen assemble sorted the problem.

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

回答を追加する

Rhyan Perso さん、ありがとうございました!
統計データを表示:

過去 24時間: 4

過去 7 日: 33

過去 30 日: 154

今までの合計 11,352