メインコンテンツにスキップ

Replace DC-in, after heat damage done by lotion

-> Is it possible to exchange the power in? <-

Or maybe i can clean it, if its not destroyed now?

I had shampoo running and the power in started smelling bad + got burned.

The laptop started normaly first though, just that i dont have a battery the laptop shutdown/crashed.

Edit: now, after one year, i checked the laptop again by plugging the (actually there is written AC)Adapter in. -> the LED doesnt glow like it is not charging, BUT there was a continous click sound (or bump) coming from that power-in [electrons?] part at about 145 beats per minute, not that loud but loud enough to be heard in a quite room

(Can i use a non-macbookpro but macbook power part as well?)

Block Image

Block Image

Block Image

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 0

5 件のコメント:

So you got something inside it if i am correct?

さんによる

Yes, green stains from shampoo.

...that day, when i checked my laptop after the incident, the dc heated up really fast which caused burning smell and breakdown of dc in (no battery= laptop went off) [or AC]

さんによる

ab90 use this guide iFixitでの質問に画像を追加する方法 to add images

さんによる

Thank you for the guide on how to add images ;) clicking on them while cursor is in text was the (very subtle) magic!

さんによる

no idea?? :o ... no one?

さんによる

コメントを追加

1 件の回答

I'm sorry but this does not look good. You have serious corrosion on the motherboard. That clicking sound is probably the power supply resetting continuously because of short circuits on the board.

The only possibility it to completely remove the motherboard and carefully clean off the corrosion. Distilled water and a toothbrush. But I wouldn't be too hopeful.

And you'll probably have to get a new charger.

このアンサーは役に立ちましたか?

スコア 0

3 件のコメント:

but the corrosion is only at the power in side!

guess the charger is maaaybe working, since it creates an electron flow ... :/

i cant buy a 'defect' macbook pro and just exchange this very unit instead of the whole motherboard?? ://

さんによる

I don't know enough about your model to say. It's possible the power entry module could be a separate part and could be replaced instead of the whole motherboard.. The charger connector looks pretty corroded too.

さんによる

Ok, thanks for your help!

さんによる

コメントを追加

回答を追加する

ab90 さん、ありがとうございました!
統計データ:

過去 24時間: 0

過去 7 日: 1

過去 30 日: 1

今までの合計 131