メインコンテンツにスキップ

2015年10月26日にリリースされた第4世代のSurface Proタブレット。

110の回答 すべてを表示

After replaced pro 4 LCD,won't turn on on battery mode unless plug it

After i replaced pro 4 LCD , won't turn on on battery mode unless plug it.

Before i take off the broken screen the pro was working good only screen was broken, so i shutted down and start working on it , after i take off the old screen i tried to connect the new screen on to try it but no response at all.

it does only work when i plug it by the charger and it does shows me that the battery is 100% full on the screen ?

and also i did put piece of paper between the connects part for the battery and motherboard and it does shows me X on the battery on the screen when i turn it on

but i couldn't solve the problem since 1 week and i'v been searching online but no one had these issue before .

so how can ifixit ??

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 2

コメント:

If you unplug it when its on, does it die instantly?

さんによる

yes it dies like there is no battery ,,

さんによる

Same issue. Putting piece of paper between battery and motherboard reports no battery, to one side reports battery capacity as -1 but centered all correct info is displayed in the battery report but as soon as I unplug it, it just cuts out.

さんによる

コメントを追加

9件の回答

最も参考になった回答

We got a couple of these SP4's in from repair shops where battery stopped working after screen replacement. Most of them had a blown diode in the charger circuit, another one a blown FET. We guessed that the display wasn't switched off when taking it off, causing the LCD backlight power buck converter to spike, but according the repairshops who sent them this was not the case. So why this is happening, we got no clue at all.

Done an SP3 as well, same sympthoms. Only way to solve it on the SP3 was to replace the battery AND the charge controller chip.

Kinda rubbish, these SP's if you ask me.

Theo | Logicboard Repair

Update (01/23/2018)

If you encounter this problem, check the two Skottky Diodes in the picture. (40 Volts / 5A). Voltage over the diode from anode to kathode should be around 0,2V. If higher, then replace. (Needless to say you have to measure this in Diode mode, with a disconnected battery). Also we encountered problems where 1 of the FET's on the control board of the battery itself went into a latch-up state. This can be solved by shorting drain and source shortly. (Be carefull!) Hope this helps someone.

Block Image

Theo | Logicboard Repair

Update (10/04/2019)

We think we found out the cause of this strange fault. The capacitor in the blue circle is very big, the slightest pressure on the metal shield cover will shortcut the capacitor and cause this failure. Make sure that you do not put any pressure on this shield, remove it and place some capton tape on the inside of the shield to make sure the capacitor cannot be shorted anymore. Again, hope this helps someone!

Block Image

Theo | Logicboard Repair

この回答は役に立ちましたか?

スコア 16

コメント:

would like to get in touch with E Surgeon - my email address is: jlsprinkle@zoominternet.net

さんによる

as u describe i check with that two diodes......they look perfect,,,,any other part to check with or any solution u found....i am having the same issue with same symtom

さんによる

Link to buy these diodes?

さんによる

@AFAQ ALI, check the FETS on the battery, see above comment.Diodes may look perfect, but do they measure correctly?

さんによる

11件以上のコメントを表示

コメントを追加

Sounds like a problem with the power manager. Do a hard reset by holding the volume up and power at same time until the machine turns off. Wait a few seconds and turn it on. Hopefully, it will work normal after this.

この回答は役に立ちましたか?

スコア 2

コメント:

while its plugged in ?

because thats the only way to turn it on

さんによる

Yes, plugged in. You want to do a hard reset while the machine is on.

さんによる

yes i tried that so many time but nothing happen ..

even its shut down if i unplug it

さんによる

コメントを追加

Also had the same issue.

Replaced LCD and doesnt turn on.

Plugged in and turns on normally. Works perfectly however as soon as remove charger, turns off.

For sure, this is not battery issue, as already tried replacing the battery.

Met last week with another tech, and he had couple of surface with exactly same issue.

この回答は役に立ちましたか?

スコア 1

コメント:

I have the same problem with my Surface Pro 4. It only works when it is plugged in. The battery is fully charged. I ran check on the battery and it is in good health. Used very little heat on it when I replaced the screen. Someone needs to solve this issue. Nothing about this problem being solved on the net, that I can fined. It is a shame that this has not been solved. There are a lot of expense pro 4's out there with the same problem. I hope that there is a definitive answer soon.

さんによる

Ifixit should be extremely pleased to have technician like Theo | Logicboard Repair on this forum. He went beyond what I expected and because of my age and hands that can no longer do fine work, he offered to repair my SP4 if I could ship it to him. He is extremely knowledgeable and the only one who knew how to solve this problem which seems to be a widespread problem occurring with the SP4's. I am very happy to worked with Theo (E-Surgeon).

さんによる

コメントを追加

Block Image

this is my device

Block Image

check diodes 1: is 1

Block Image

check diodes 2: is 192

この回答は役に立ちましたか?

スコア 1

コメント:

Hello,

I have the same board and it will not run on battery. When I check the same diodes I get the following, No Battery and no power #1 is at 201 and #2 is at 202. When I apply the power #1 becomes at 193 and #2 at Minus 422.

I also looked everywhere for a schematic but no luck.

I feel it is a possible ground issue with the power adapter, i will give you more details next week when i confirm my thought.

さんによる

Also possible that one of the FET's on the battery board itself is in a latch-up state. Carefully short source and drain with a plier shortly and reattach the battery. This happened here as well and this procedure brought the FET's back into a normal state.

さんによる

I would like to try this. Can you possibly provide an image or further explanation of "drain with a plier".

さんによる

Thank you Phạm Như Đông. Appreciate the good work.

さんによる

@E-Surgeon Hello. Please can you elaborate on how I drain power with pliers as realise this may be dangerous if I do it wrong and short circuit the wrong bit. Would really help thanks.

さんによる

3件以上のコメントを表示

コメントを追加

I wish someone would solve this problem, which I also have.

この回答は役に立ちましたか?

スコア 0
コメントを追加

Hey guys my SP4 started having this symptom 3 days ago, I didn't even crack/replace the screen. It just happened on its own. It only runs on charger now and battery is fully charged. I contacted support but they were no help, they offered to replace the device for $450 as it's out of warranty.. it's like we have $450 laying around every time this $@$*!& device breaks.. I already replaced it for phantom touches and now this.

I do iPhone/iPad maintenance and I'm good at micro-soldering too, so I'll probably pop this open soon as I have time for it. So are there any schematics/board views out there for it? I'll order a new battery pack too in case it was a bad battery.

Also I'd love a site where I can find a genuine battery pack. Thanks!

この回答は役に立ちましたか?

スコア 0

コメント:

there are no schematics and no boards for this device publicly accessible. it's %#*@ a shame that there isn't a definitive fix for these devices.

さんによる

コメントを追加

No schematics / boardviews available, we had to figure it out on our own. Dunno about the battery packs.

この回答は役に立ちましたか?

スコア 0

コメント:

I have changed out screens on iPads, Samsung tablets, and changed out batteries on several small electronics. I usually do it right, and save money. But this time I a having a problem. I replaced a battery and a screen on a Microsoft Surface Pro 4 after the screen shattered. I can't get it to come back on. Do you do repairs or know someone who can check it out? This is my son's computer and I am trying to get him back up and going for his last semester in college. I have not sealed up the new screen yet.

さんによる

コメントを追加

Also we encountered problems where 1 of the FET's on the control board of the battery itself went into a latch-up state. This can be solved by shorting drain and source shortly. (Be carefull!) Hope this helps someone.

Can anyone elaborate or clearly explain what this means?

この回答は役に立ちましたか?

スコア 0

コメント:

Can't make it clearer then this: https://en.wikipedia.org/wiki/Latch-up

さんによる

コメントを追加

The battery needs to be replaced, if you put the device in a heater to remove the screen then the heat likely damaged the battery

この回答は役に立ちましたか?

スコア -1
コメントを追加

回答を追加する

Mike ali さん、ありがとうございました!
統計データを表示:

過去 24時間: 6

過去 7 日: 21

過去 30 日: 131

今までの合計 3,872