Skip to main content

2.26 or 2.4 GHz / White plastic unibody enclosure

683の回答 すべて表示

SMC problem in A1342

Hi everyone! Sorry for my english. Hope you understand.

I have an A1342 Macbook White. It was working fine, but I decided to install an SSD drive. After that, I'm having an strange SMC problem.

OS X (El Capitan) install was succesful, but Macbook's only way to boot up is holding the power button for almost 15 seconds. Magsafe led's green. Led light indicator goes crazy : blinking, smoothing, etc.

When it finally power up, fan speed is really high, battery is not detected, and system runs very slow.

I've tried installing again the original HDD, but nothing happened.

I already had this problem whit another A1342, and resetting the SMC solved it. But... When I try to reset the SMC in this Macbook, it just doesn't do anything! Doesn't even try to boot whit the reset SMC's keyboard combination pressed.

If I keep pressed the power button, it "starts" to boot, but, if I press the combination, it inmediatly power off.

Any answer will be useful! Thanks, and sorry again for my english.

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 0

コメント:

Can you give us the make & model info on the SSD you put in.

による

What happens when you put the original HD back in does the system work then?

による

Thanks for the answers! SSD is a Kingston UV400, 120GB, SATA3. I've installed it in many macbooks like this one and never had a problem before. If I put the original HD back, it stills having all the issues Ì comented.

による

Your systems specs: MacBook 13" 2.4 GHz Core 2 Duo (Mid-2010)

Your SSD's specs: Kingston UV400

による

コメントを追加

MacBook Battery 修理キット

最低価格 $69.99

Buy Now

MacBook Battery 修理キット

最低価格 $69.99

Buy Now

1回答

最も参考になった回答

The SSD is compatible as it auto senses the systems SATA port which is SATA II (3.0 Gb/s). So thats not an issue here.

I'm suspecting the drive cable might have gotten damaged. Do you have access to a second Mac system which you can connect to this one and then put the system into target mode? If you can try running Disk Utilities First Aid to see if the drive is OK (it makes no difference which drive you have installed here). If the drive comes back with errors then I would replace the cable. Here's the IFIXIT guide: MacBook Unibody Model A1342 Hard Drive Cable Replacement.

If you can't get the system into Target Mode, you have bigger problems.

この回答は役に立ちましたか?

スコア 2

コメント:

Hi again, Dan! And thanks once again for your answer. It is not the cable. It works fine. Both HDD and SSD works fine. The problem here is the SMC.

Fans are running at fast speed all the time, system hour resets every time I unplug the computer, and battery isn't even recognized.

による

mmm... I think you gave us a new clue here! You are loosing the Date & Time! That would imply the battery was bad. Do you have a spare to try out?

による

I recently did that. Took off the battery from the problematic Macbook and put it in a working one. It was 0% and no charging. I did an SMC reset in the good Macbook with the bad battery, and it started working! Now is charging fine! :D

But.... I put the good battery fully charged from the working Macbook into the bad one, and it still doesn't turn on normally :(

I'll update in few hours.

による

It's starting to sound like the logic board has issues then if you've tried a good Batt. Does it look like it got wet? Any staining or signs of corrosion?

による

No water, no liquids, no nothing. It didn't work. Battery works fine, HDD and SSD works fine, but the SMC has gone crazy, and it seems like there's nothing I can do... Any idea?

PD: ASD tests says SMC is working fine :/

による

コメントを追加

回答を追加する

Nico Corradini さん、ありがとうございました!
統計データを表示:

過去 24時間: 1

過去 7 日: 5

過去 30 日: 18

今までの合計 519