メインコンテンツにスキップ

2001年に発売された任天堂ゲームボーイアドバンス。修理は一般的なツールがあれば対応できます。

30の回答 すべて表示

No power, clean battery terminals, F1 fuse works

I just recently got in two game boy advance units (AGB-001) from Japan and off eBay. Both units will not power on and I've tested good, working batteries. I've also opened up both systems and checked the F1 fuse located right next to the NEG power terminal. The fuse appears to be working properly. I've used a multimeter on continuity mode to verify that it's giving the appropriate reading.

The PCB also appears to be spotless. I've looked over the board, there is no battery corrosion. There doesn't appear to be any bad traces or burnt out or damaged components. Initially, I thought I saw the 2nd device flicker green and red in the power LED but I haven't seen anything since I initially tried turning the game systems on.

The only thing I could think is that the power switch might be bad. I'm not entirely sure how to test the power switch to see if it's working properly.

Does anyone have any idea what might be stopping this unit from powering on?

Thanks for any advice you could give!

回答がありました! View the answer 同じ問題があります

この質問は役に立ちましたか?

スコア 1
コメントを追加

Apple Watch キット

スクリーンとバッテリー の修理が簡単にできます。

ショップを見る

Apple Watch キット

スクリーンとバッテリー の修理が簡単にできます。

ショップを見る

2回答

選択されたソリューション

So, I finally have an answer to my own question! Turns out it was a bad power switch, well not "bad" but it needed some cleaning.

I got two GBA units in from Japan with the same problem, great battery terminals, working fuse but no power at all when switched on. I did notice that the blue unit would flicker power when I switched it on and off. So I slowly moved the power switch and at about 55% on, the unit would power up and the games would play.

That got me curious, so I took the pink unit (since it wasn't working at all) and opened up the power switch. You can see what it looks like here. It's actually a pretty simple design. There are three metal contacts and the slider has two very tiny metal prongs that contact only two of the three pads at any time. In the provided picture, inside the slider, you'll see those three metal pads and they look very dingy. I took a small piece of 600 grit wet-dry sandpaper and cleaned up those three areas. I also lightly sanded the slider as well.

When I reassembled the pink unit, it powered on like a champion! I was very happy to have found the issue and jumped right onto the blue one and gave it the same treatment. Sure enough, the blue powers on with no issues at all. Both units work great after I gave it my typical cleaning and further refurbishing. I almost want to keep one of them just for the satisfaction of solving this mystery.

この回答は役に立ちましたか?

スコア 5
コメントを追加

Can you revise that picture link? I have a gba agb 001 with battery corrosion that seeped into the on/off switch and around the start/select buttons.

この回答は役に立ちましたか?

スコア 0

コメント:

It appears I've lost that image to time and space. The best suggestion I have for you when it comes to battery corrosion is using White Distilled Vinegar to eat away at any corrosion first. Once that's been dissolved bye the vinegar take some high concentrate IPA (Isopropyl Alcohol), 90%+, and clean off the vinegar with that. Afterwards, your device should be cleaned up and ready for testing. Make sure to let the IPA dry off as well before turning your machine on.

による

コメントを追加

回答を追加する

Andrew Fillhart さん、ありがとうございました!
統計データを表示:

過去 24時間: 7

過去 7 日: 32

過去 30 日: 112

今までの合計 2,333