Why are my fans constantly running?

A bunch of my keyboard keys didn't work, so I replaced the keyboard without any problems... Well... No problems with the keyboard replacement, but now the fan constantly runs at full speed. I have SMCControl running and it reports that the temperature is 39 degrees C, and yet the fans are running at 6000 rpm.

While I was inside my laptops innards I blew out as much dust as I could with canned air. (Amazing how much there was... Ick...)

I don't understand why the fans would be running at full speed if the temp sensor reports that the temperature is low.

Can you help me out? I appreciate it.

回答がありました! View the answer 同じ問題があります

この質問は役に立ちましたか?

スコア 1
コメントを追加

Pro Tech ツールキットを含むご注文、もしくは総額 $100ドル以上のご注文については送料無料です。

当社のショップを閲覧する

3回答

選択されたソリューション

Usually that problem is caused by disconnected thermal sensors. Check the left and right thermal sensors to make sure they are plugged in. You can see where the thermal sensors are plugged-in on step 16 of the left thermal sensor guide. The left thermal sensor connector is located in the middle of the upper half of the logic board and the right thermal sensor connector is located just below the right fan connector.

MacBook Pro 15" Core 2 Duo Model A1211 Right Thermal Sensor画像

ガイド

MacBook Pro 15" Core 2 Duo Model A1211 Right Thermal Sensor Replacement

難易度:

難しい

MacBook Pro 15" Core 2 Duo Model A1211 Left Thermal Sensor画像

ガイド

MacBook Pro 15" Core 2 Duo Model A1211 Left Thermal Sensor Replacement

難易度:

難しい

この回答は役に立ちましたか?

スコア 1
コメントを追加

This could also be due to a different problem. Check your activity monitor for any processes that run higher than, say 80% at all times.

It could even be a bad printer driver with a stuck print job, so maybe you should also check your print queue...

この回答は役に立ちましたか?

スコア 1

コメント:

I'll take a look at this when I get home to the computer.. I don't think it's a process issue, though, because the temperature never climbs about 40 degrees. Though, if I did accidentally disconnect one of the thermal sensors, then it could be both!

Thanks for the help!

による

コメントを追加

I had the same problem on a MacBook Pro 8,2 (2011). After disconnecting all devices, I shutdown and reset the SMC which didn't appear to help all on it's own.

After rebooting, the fans started again at 100% and so I put my MacBook Pro to sleep via the top left Apple sleep menu item. Then waited for a minute or two and the fans finally turned off. Then I closed my Macbook Pro, and reopened it, and logged back in and the fans were working properly again.

(Note I also tried running smcFanControl before resetting the SMC but it didn't have any effect on the fans).

この回答は役に立ちましたか?

スコア 1
コメントを追加

回答を追加する

Ashersdad さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 1

過去 30 日: 4

今までの合計 2,778