メインコンテンツにスキップ

10.1" tablet released in February 2014, powered by a custom version of Android 4.4 KitKat, and identified by model number: SM-T520NZKAXAR

34回答 すべてを表示

Won't turn on, won't charge battery

Hello! I open this topic becouse I think this is a diferent problem from the other topics.

I try to fix a SM-T 520 how won't turn on. I replace the USB charge flex cable but it Still not working. With multimeter it is possible mensure 5,4V in one diodo in motherboard when it plug to charger (the current arrives to motherboard) , but in the battery plug pin's arrives only 0,2V how it's not enought to charge battery. The battery shows 3,7V and I think it's not enought to turn on the device. Next week I will try to connect to a variable power supply to know if is a battery problem but I don't beleave. I try every possible reset solution but it don't turn on and it don't show's any led light when it plug to charge. Thank you

Update (10/04/2015)

Block Image

Picture from the motherboard

Update (10/05/2015)

Block Image

Another picture from the motherboard.

回答がありました! 回答を表示 同じ問題があります

この質問は役に立ちましたか?

スコア 2

コメント:

Good picture but it shows only part of the board. For the charging circuit we need to see the rest of it as well.

さんによる

Its further to the left under an EMI shield :-)

さんによる

さんによる

コメントを追加

1 件の回答

選択されたソリューション

rubenmplopes, just because you got some 5.4V on a random diode, does not mean that your charge connector is working. I would suggest that you measure on the connector itself. If you only got 0.2V on the battery connector and if your charging port shows the proper voltage on the pins, then you do want to check the power management IC as well as other components on your charging circuit.

Block Image

Update (10/04/2015)

Use this guide to add images.

Block Image

このアンサーは役に立ちましたか?

スコア 1

コメント:

Thank you for your answer. I allready check the charger cable how plug to motherboard and somewhere in the ribbon cable I mensure 5.4V. Next step is find the power manager IC... I can't find any motherboard schematic on web... Another thing I forgot to tell is the tablet works fine untill battery drained. After it don't charge and don't shows any signal.

さんによる

"untill battery drained" sounds like either a bad battery or bad PMIC. Post some good pictures of your logicboard with your question, that way we can identify a few parts for you.

さんによる

You can see the picture from the motherboard

さんによる

I post another photo

さんによる

Hello oldturkey03 did you find any solution? Thank you

さんによる

コメントを追加

回答を追加する

Ruben Lopes さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 0

過去 30 日: 4

今までの合計 2,375