1.7GHz デュアルコア Intel Core i5(Turbo Boost使用時最大2.6 GHz)3MB L3キャッシュ

113の回答 すべて表示

magsafe powering computer but not charging the battery

After mild liquid (cat pee) damage near the left (charger, USB, headphone jack) side, magsafe light will not come on.

The computer shows the charger icon with no "lightning bolt" and the battery says 0%. It appears to be getting power from the charger, since it has not died even though it's been a couple of months since this happened.

The USB and headphone jack work.

At the genius bar, they opened it but would not fix it once they saw it was gross liquid damage. They did not say where the damage was (or I didn't hear it).

Otherwise the computer works perfectly. Do I need to replace the left I/O board? (the charger works on a different mac). Any guidance would be much appreciated.

回答がありました! View the answer 同じ問題があります

この質問は役に立ちましたか?

スコア 1

コメント:

I am interested to hear what you came up with. I have the same issue that you're having. I didn't have any water damage though. The system information still lists my battery condition as normal. I ran the apple diagnostics, did a SMC reset, everything, and still no light.

That said I have yet to try another charger. Did you get a replacement battery? Did that fix it?

による

コメントを追加

Pro Tech ツールキットを含むご注文、もしくは総額 $100ドル以上のご注文については送料無料です。

当社のショップを閲覧する

1回答

選択されたソリューション

That would be a good place to start... you may also need a new battery.

Carefully cleaning the logic board of any corrosion would also be wise. as corrosion worsens over time, and bridging may occur.

If this answer is acceptable please remember to return and mark it.

この回答は役に立ちましたか?

スコア 1
コメントを追加

回答を追加する

Swerve さん、ありがとうございました!
統計データを表示:

過去 24時間: 1

過去 7 日: 2

過去 30 日: 6

今までの合計 389