A wide range of repair guides and support for the consumer-grade laptop computer line by Toshiba.

936回答 すべてを表示

Toshiba Satellite C50-A - Touchpad not working after boot?

Note: This laptop has since been out of my hands, however, you are still welcome to post what you think might help. Thanks!

It seems that I have gotten into yet another "pickle". This one I've scoured all over the internet for answers, and it's not a laptop that I have too much control over.

The laptop I need to service now is a Toshiba Satellite C50-A. (Product description below) I've already looked everywhere possible on the web doing all sorts of things BUT a system restore.

My main issue here is the Touchpad. It's a Synaptics, and it likes to prank me. When the computer first boots to the "Lock screen" the Windows 8 system has, it works fine. When you go to put the password in, it stops dead. Afterwards, it's a minor on/off thing, seemingly coming back as a stroke of luck (or unluck). In order to use the cursor, you'd need to plug in an external device, which is tedious when you just want the touchpad, not needing to worry about a sliding mouse.

It seems to be primarily connected with the keyboard, as it's the only time that when a key is pressed that the touchpad stops functioning.

I would greatly appreciate support A.S.A.P. for this.


Toshiba Satellite C50-A

Part #: PSCF6U-0H306R (How I got Drivers)

Serial #: 2E139872Q

Runs Windows 8.1, still has Toshiba Limited Hardware Warranty. Limited Warranty does not cover software.

Has latest Drivers.

Has Anti-Virus Software (Norton 360). Also has been scanned.

I have tried almost every little action available as of right now (remove battery, hold Power button for 50 secs, startup; uninstall/reinstall drivers; etc.).

It seems like this is a discontinued model, seeing as the Serial number is no longer registering on the Toshiba Support website.

If the problem is internal, not software, I have to notify the owner that he'll have to send it of for the Warranty. I will NOT take it apart myself.

I am a one-man repair service. I know the Technical terms so go ahead.

Thanks in advance, -Andrew

After Info: I Am POSITIVE and have checked it many times, that it is not OFF by the F6 key (Or what it was).

回答がありました! 回答を表示 同じ問題があります


スコア 1


I have this problem too. I've onlt had mine for four though.





Hey Andrew, If you really did every software possible action on your opnion, I could only strongly think and suggest that you make your laptop fixed by your warranty, before it runs out. seems to me there is either the front keyboard and trackpad are not fully plugged inside or that they are progressively damaged at one future point it could fully stops. I cant really suggest much more.

if you would like you could try that:

I always get my computers driver using this French website, they are really good to find the right drivers, this website managed to find drivers I never ever tough would find.

I would recommend you to uninstall every trackpad driver and than go to this website(Link a bit bellow). You could use google translate to give a extra translation and get whats going on. I did some quick screenshots showing you by some quick explanation were to go, you will need to install some plugins in between step 1 and 3 I could take a pic because I already installed it ;). Cheer


Step 1

Step 2

Step 3

Step 4

Step 5

Or just use Google translator instead of those poor quality images, If my mac wasnt broke I would had done nicer :)


スコア 1


PS. Gosh my english was poor so sorry, I am not English so please forgive me, I will give a quick edit and try to fix a bit.


2PS: After thinking a bit more, I doubt is a driver problem, because a trackpad without driver would had come with primitives functions, but would always work without trouble, drivers would theoretically only allow some new features and more precision control, Could be that actually is your keyboard who is with defect, for example, and by unluck, its affecting the trackpad, without opening and making some test I can't tell more sorry


It's quite alright, and your English is good. Nothing to be sorry for if you are still learning. I think it is more-or-less an incompatibility between technologies, or maybe a plug isn't in quite the way it is supposed to be, or even the Logic Board is messed up in some way. Either way, I have tried all I could with drivers, and it still didn't work (I've literally devoted over 20 hours of my time researching and trying methods). I may require to tell the owner that he would need to put it in for the Warranty.


I would definitely contact the seller and use the warranty of the product.

if this answer satisfy you than please dont forget to select as accepted on the top right. thanks



press fn and every key button on laptop and will turn back on, happened to me apparentl y fn and a random key turns touchpad on and off.


スコア 2


Brilliant. Thanks for posting your solution. This worked for me!

It's worth pressing FN and the F5 key. Touchpad is now working again :)



bold textsame problem,

Like what was said i tried the whole f5/f9 and the battery out for 50 seconds but still the problem occurs. i turn the laptop on punch in the password and then 15-20 seconds after the touch pad stops working. it works here and there for a split second and then stops again any other ways of fixing this issues would be much appreciated.


スコア 0


It seemed to work after a fresh reformat. What caused it is still unknown. Haven't had a cal back yet, so it seems to have stuck.



Look at the f5 key, it's secondary function (or primary depending on how you set up the keyboard in the BIOS), is to turn the trackpad on and off. you probably hit it by accident.

There are loads of posts on various web sites about people installing older drivers and they work for a while, and people returning laptops to manufacturers because the hardware is faulty.

I've just spent hours installing and re-installing different drivers, with no success, even following the advice on this page. Then I stumbled across a post on another site that mentioned a hot key combination to enable / disable the trackpad and the penny dropped...


スコア 0


Paul, as I mentioned in the Afterward Info at the bottom of the post, I had ensured that the laptop model did not have the F5/F6 (Touchpad on/off) key in an "off" position, and in fact, from memory, even tried that button several times during initial testing.

It has since been out of my hands, but perhaps this article might help others. However, thank you for your input. :)




Andrew さん、ありがとうございました!

過去 24時間: 4

過去 7 日: 21

過去 30 日: 94

今までの合計 20,417