メインコンテンツにスキップ

修理を始めるには

修理する権利

ストア

モデル番号A1311 / Mid 2010 / 3.06 & 3.2 GHz Core i3もしくは3.6 GHz Core i5プロセッサ

359の回答 すべてを表示

LCD not working after ssd installation

Hi there,

after succesful installation of a ssd, I damaged display data cable and afterwards the the lcd of my imac stays black. Computer is booting and running normal, an external display shows picture.

Diagnose LED4 stays black, all others are green.

I already bought a new display data cable and a new backlight inverter board but both with no result - the lcd stays black.

No i´m wondering what it could be, because I don´t want to buy a new lcd if it´s not necessary and I already spent a lot of money with no result.

Every help is very much appreciated.

Sorry for my bad english, I´m from germany ;-)

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 0
コメントを追加

2件の回答

It is unfortunately very common for people to damage either their display cables or the actual display cable connector on the logic board. I can only speculate because I cannot examine it myself, but I would be willing to bet that you accidentally damaged the connector on the logic board, which could possibly require professional soldering skills to repair.

Does the connector look damaged at all? If the connector looks fine, try to examine the pins inside it. Are any of them bent or out of place?

If you look at the guide to remove the display, iFixit warns that the display data cable and display data connector are very easy to damage, and in the comments below, other people agree.

この回答は役に立ちましたか?

スコア 0
コメントを追加

The connector does not look damaged. Also the inside seems to be ok but that´s hard to say. I cannot see an obvious damage.

この回答は役に立ちましたか?

スコア 0
コメントを追加

回答を追加する

delbracht さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 0

過去 30 日: 0

今までの合計 207