iPhoneの5代目となるiPhone 4S。このデバイスの修理は比較的簡単で、スクリュードライバー、開口ツールと忍耐が必要です。GSM/CDMA / 16, 32, 64 GB / 白と黒

2993の回答 すべて表示

iPhone 4s Error 29, changed battery - nothing works

So I dropped it on the floor, It worked fine until it discharged a day later, It wouldn't recharge, went into restore mode got error 29 restore loop. Tried DFU same results.

Got a new battery, nothing changed. Took it to a shop they said board is busted I should buy a new phone.

I'm posting the error log here maybe someone has an idea what's wrong.

[18:54:27.0553] entering update_gas_gauge

[18:54:27.0553] AppleImage3NORAccess::_getSuperBlock imageVersion: 3

[18:54:27.0553] AppleImage3NORAccess::_getSuperBlock imageVersion: 3

[18:54:27.0553] [nand_part_core:INF@2289] first 2 pages of boot blocks written with copies of partition table

[18:54:27.0553] [nand_part_core:INF@3169] next 98 pages of boot blocks written with LLB image of size 150080 bytes

[18:54:27.0553] [nand_part_core:INF@3172] final 156 pages of boot blocks written with random data in full page format

[18:54:27.0553] 0: RamrodErrorDomain/3ea: update_gas_gauge: gasgauge_swupdate returned -1

[18:54:27.0553] restore failed with CFError:

[18:54:27.0553] 0: AMRestoreErrorDomain/1d: failed to update device firmware

[18:54:27.0553] 1: AMRestoreErrorDomain/1d: ramrod firmware update failed

[18:54:27.0553] 2: RamrodErrorDomain/3ea: update_gas_gauge: gasgauge_swupdate returned -1

[18:54:27.0553] waiting for host to acknowledge final status received...

[18:54:27.0553] host received final status

[18:54:27.0553] attempting to dump restore log

Thank you in advance :)

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 0
コメントを追加

Pro Tech ツールキットを含むご注文、もしくは総額 $100ドル以上のご注文については送料無料です。

当社のショップを閲覧する

3回答

最も参考になった回答

Replacing the battery mostly resolves this issue.

If this does not do it, replace the chargeflex also.

この回答は役に立ちましたか?

スコア 1
コメントを追加

Just went through this and the battery change did the trick.

この回答は役に立ちましたか?

スコア 0
コメントを追加

Basically if you've exhausted all the other fixes... changing the battery,removing firewall,antivirus,editing host file etc etc. Then check the last line of your itunes restore log if it says something like...'RamrodErrorr domain/3ea: update_gas_gauge: gasgauge_swupdate returned -1' ... Ifixit has the answer and more details here.....

Enable GPS even when phone is off... .

この回答は役に立ちましたか?

スコア 0
コメントを追加

回答を追加する

Shaise さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 5

過去 30 日: 13

今までの合計 4,454