メインコンテンツにスキップ

Cannot type capital letter R with Shift-R keys

I own an early-2008 15" MacBook Pro Core 2 Duo (Model A1260 w/ Penryn) and from the day I purchased it from Apple, the Shift+R key combo has never worked. When attempting the Shift+R key combo, the system makes an audio "bloop" sound and nothing appears on-screen, regardless of the application.

I took the machine to the Apple Store the week after purchase and they were able to use an external bootable drive to determine the problem wasn't hardware-based, so they prescribed a 'clean install' of OS X.

Long story short, I've tried a number of options, including clean installs and revisits to the the Genius Bar to confirm the problem persists and is not a figment of my imagination.

Again, the most recent recommendation was to perform another clean install on the OEM Hitachi 200GB 5400rpm SATA drive. Not only did I clean install OS X, I zeroed-out the drive before partitioning and reinstalling OS X (10.6.3 aka Snow Leopard).

I subsequently updated the OS to 10.6.8 via Software Update and the system ran fine... until I tried to bring my legacy user profiles and documents over using copies from SuperDuper and Carbon Copy Cloner (i.e. tried both approaches) via Migration Assistant and discovered that the Shift-R problem is somehow tied to my legacy user account profile.

I also tried starting again from scratch and manually copying files from my back-up hard drive to all the correct sub-directories, but I always seem to get tripped-up with sub-directories 5 to 6 folders deep getting misplaced.

I finally found a clue which hopefully will provide the diagnostics necessary to find the answer to this issue. I created a secondary user account and the Shift-R problem doesn't appear with that account!

So, I need to figure out either how to repair the problem in my primary legacy user account, or determine how to move all my legacy documents, applications and file libraries (such as iTunes) from the the corrupted legacy user account to a new user account.

I'm willing to take the time to zero-out the 200GB internal drive AGAIN and start over if I can get the proper guidance on how to finally navigate getting this bug removed once and for all time!

I'm dying to finally resolve this issue, especially since I have a brand-new Crucial/Micron M500 480GB SSD ready to be installed as the replacement internal HD.

Thanks!

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 0
コメントを追加

iPhoneのバッテリーキット

Only $29.99

Buy Now

iPhoneのバッテリーキット

Only $29.99

Buy Now

3回答

You didn't need to format anything. In the keyboard preferences, shift-R is most likely assigned to a command. Look through it and then change it.

この回答は役に立ちましたか?

スコア 0
コメントを追加

Dear Jack Ryan,

This was a Clear and Present Danger, so it's one of the very first things which I, then Apple Store "Geniuses", explored to rectify the problem. Just to humor you, I again reviewed and turned-off ALL Keyboard Shortcuts. Zip, zilch, nada. Other ideas?

Cheers,

Duane

この回答は役に立ちましたか?

スコア 0
コメントを追加

Hmmm, we have the same problem with shift-r not producing any text action. We will try just creating a new account, since we are using OSX 10.6, which cannot be re-installed even from the newly purchased "factory installation disk" from Apple :(! Thanks to OP for that possible solution!

この回答は役に立ちましたか?

スコア 0
コメントを追加

回答を追加する

duanev さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 0

過去 30 日: 8

今までの合計 706