メインコンテンツにスキップ

iPhoneの5代目となるiPhone 4S。このデバイスの修理は比較的簡単で、スクリュードライバー、開口ツールと忍耐が必要です。GSM/CDMA / 16, 32, 64 GB / 白と黒

2997の回答 すべて表示

Mind Boggling Headphone Jack Issue!

Help Save My iPhone Before it Gets the Sledgehammer

So, I replaced my power sensor cable and everything went fine. Put everything back together, phone worked fine so I went to bed thinking "this rocks! my power button finally works again."

Woke up in the morning and took a trip to the gym to get a workout in which I thought would be even better than it had been in months since I could now turn my screen off whenever I wanted to. So I go to start working out, plug my headphones in and press play. Here's where the mystery comes in...

When the headphones aren't plugged in, the phone plays audio perfectly, the volume controls function perfectly, and everything works great. Once the headphones are plugged in, things start acting buggy. the volume controls, whether using the buttons or controlling using the on-screen slider wont control the sound the way they should. when you turn the volume up all the way, the sound is blaring out of the headphones to the point where its about to blow the speakers. when you turn the volume down, the sound levels lower slightly until about the half way point then beyond that it doesn't ramp down. As you move the volume slider down to the lowest point, the sound just "clicks" off at the lowest point. Then, when you move the volume slider up a little, the sound will abruptly click on again. As you move the volume slider around, you will hear static, distortion, and sometimes the music will just cut off.

A couple things to mention. First, it's not the headphones. I verified by using the headphones on my girlfriends iphone and they sound fine. Also tried plugging my iphone into the aux jack in car and had the same issues. Second, the audio plays fine through the dock connector.

I decided to retrace my steps and tear the phone back down. My initial thoughts were a grounding issue. I was extremely careful with the ribbons during the power sensor replacement and I don't see any signs of damage whatsoever on the headphone/volume control ribbons nor the connectors.

At this point, I went through with rubbing alcohol and cleaned all metal contact points on the logic board and all connectors. Also checked to see that grounding clips were placed correctly and making contact where they should be. Everything seemed to be completely in order, no signs of stray dust or bad grounds. The headphone jack is clear inside and I have blown it out with air so the jack is not the issue. It has always worked fine up until the power sensor cable replacement.

Well, hopefully someone has some ideas. I have searched everywhere for this issue and have found some posts from people that had similar "headphone static" issues and the issue continued even after they replaced the headphone jack, cable and connector. The other people with this ongoing issue seem to never find an answer so I hoping some "Mac Genius" will know this one. Thank you for your time.

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 4

コメント:

Have you tried forcing a cloth down into the jack and allowing it to soak up any moisture?

による

if it doesnt work while its not assembled then its definitely defective... i would of automatically replaced it honestly because if its plugged in and responds it works but the headphone jack is just giving problems... i hope its gsm because the volume cable in cdma is a biotch to install..

による

コメントを追加

iPhoneのバッテリーキット

Only $29.99

Buy Now

iPhoneのバッテリーキット

Only $29.99

Buy Now

3回答

最も参考になった回答

in some rare cases the IOS can get buggy after repair i haven't got a clue how that's even possible with no power in it, but after doing repairs at my repair shop we get 1 out of 50 iphones have a buggy glitch in the ios after repair and the only real way to fix it is a restore in itunes. not saying its your problem but it might be and simply restoring it cant hurt to try.

この回答は役に立ちましたか?

スコア 1
コメントを追加

Turn it off then turn it back on

The apple products don't work well if they stay on all of the time.

この回答は役に立ちましたか?

スコア 1

コメント:

You are a life saver thanks man, saved me time, if i could i would pay u

による

コメントを追加

verify that the audio jack is fully seated, in other word maybe the location of the receptical is not allowing the plug to get in all the way. there are four contacts that need to line up correctly.

you might try testing it unassembled if possible to find out if something is being pinched ect.

good luck

この回答は役に立ちましたか?

スコア -1
コメントを追加

回答を追加する

Shawn さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 0

過去 30 日: 3

今までの合計 12,867