メインコンテンツにスキップ

修理を始めるには

修理する権利

ストア

ヘルプ

オリジナル投稿者: jayeff ,

テキスト:

Hi,

Did you disconnect the battery before you dis-assembled it again to check the connectors?

I realize that you said that the logo flashes once or twice but when the display turns black, try shining a torch at an angle close to the screen and check if you can detect any images at all. They will be very faint so trying this in a darkened room may help to see them if they are there.

If they are there then there is a backlight problem although since you get the logo this means that the backlight power supply is basically OK and it may possibly be a connection problem.

I don’t know about your model laptop but with a lot of laptops the backlight power is always being supplied to the screen and a signal is sent on the backlight enable lead between the motherboard and the screen to either turn the backlights on or off.

Without a schematic of the board or the datasheet for the display panel it is hard to know which wire it would be on between the two. Maybe try searching for ''(insert motherboard’s board number) schematic'' or if you still have the old display panel, ''(insert make and model number of display panel) datasheet'' to hopefully get a result. The board number is printed on the motherboard itself and the display make and model number should be on the back of the display somewhere.

Try getting into BIOS and check if there is a display and that it stays on. Just an idea as during POST the display is controlled by the BIOS but once it boots and loads the OS it is controlled by the video drivers telling the BIOS what to do.

ステータス:

open