Skip to main content
ヘルプ

オリジナル投稿者: Charles Sporkman ,

テキスト:

I have the same model and after a number of logic boards and pretty much everything else during the warranty period, the overheating continues.  It got really bad during the 10.6 install - system actually hit the hard temperature limit and shut down.

Since the warranty was up, I decided to open the thing up and see what I could do as far as removing 4+ years of dust.  There wasn't much in there.  I then decided to replace the heatsink compound.  What was there was a bit excessive - it oozed well beyond the chips.  I cleaned both surfaces then applied new (although not high quality) paste with a bit more restraint than the repair depot folks did.

It got a bit better, but any cpu-intensive task (for example, HD Netflix) would eventually bring the temperature to the 210F shutdown point.  Further experimentation showed that basically anything that pegged the CPUs would result in both fans going to their max RPM (somewhere around 6000) but the temperature would eventually reach the shutdown point.  I watched the CPU temp and various sensor temperatures with istat, Temperature Monitor, and a few other utilities.  It seems like the sensors are all reporting correctly but the heat simply is not transferring from the CPU to the heatsink very well.  CoolBook is the only thing keeping this thing vaguely usable.  It's odd OS-X does not actually try to clock down the CPU as the temperature hits 200F or more though.

Anyhow, my next theory is that I'm basically dealing with a flawed design.  If you compare how the heatsink is secured in the non-unibody MBPs to the unibody models, you can see a very big change.  The old MBPs simply "sandwich" the heatsink between the mounting standoffs of the bottom case and the mainboard.  On the unibody MBPs, there are springs involved the ensure that the heatsink is firmly seated against the chips.  Given the amount of flex in the old MBP bodies, I'm beginning to think that the heatsink is simply not making firm, constant contact with the chips.  I'd really, really love to see one of the ifixit crew look at this - it would be awesome to actually find the root cause of this all too common issue.

My next step is to try and find something that I can epoxy to the bottom case under each chip that can apply pressure to the heatsink to try and get a more solid bond between the chips and the heatsink.  It sounds nuts, but I've got a few ideas swirling around...  Any feedback would be welcome. I'm not ready to ditch this laptop until there's a truly hackintosh-friendly laptop.

ステータス:

open