メインコンテンツにスキップ
ヘルプ

現在のバージョン作成者: Lucas Silva ,

タイトル:

Dead MacBook Pro with flashing battery indicator

テキスト:

So I have a MacBook Pro, unibody, early 2011.
 
The machine doesn't boot up, it just lights the battery indicator five times when pressing the battery indicator button. After some presses, only one light appears to blink (five times again) and then suddenly stops responding.
 
The battery indicator lights are only seen with the MagSafe connected. And the MagSafe light stays green forever. (went orange one time and then returned to green). Without MagSafe, it's 100% dead.
 
Tried to heat the board, no success. MagSafe charger is 85W, so no problems with lower chargers.
 
Any ideas on how to solve this issue?
 
Thanks in advance.
 
EDIT: the machine doesn't boot up even without the battery (MagSafe only).
 
=== Update (11/03/2017) ===
 
PS #1 - Nov 3rd
 
So I just got a 60W charger (aftermarket) to test with this MacBook Pro.
 
The results are "better", on par to what I expected. The machine still doesn't boot, with or without the battery (MagSafe only). However, the 60W MagSafe appears to fix the "death" of the battery indicator lights (finally).
 
So it starts with a blinking LED for a few seconds, and then "upgrade" to the full LED blinking five times. I didn't receive the battery yet - maybe next week.
 
Q: MacBooks are able to power on ONLY with the MagSafe power?
Q: MacBooks are able to power on ONLY with the MagSafe power?
 
=== Update (04/22/2018) ===
 
Months after my initial question, I decided to take a very deep and closer look on the board to see if I was missing something. Turns out I'm really missing some important topics:
 
1. The A1278 schematics shows that the ISL6259 is probably the culprit of unbootable MacBook Pro boards. Problem is, my board is MISSING ISL6259 (AKA U7000), so this explains why it doesn't work at all. AFAIK, someone removed the chip and tried to solder it again, but failed miserably. I've already ordered some chips (pack of 5) and I'll let you guys know what happened.
 
2. I do have PPBUS_G3HPP3V42_G3H, so this explains the green light on the charger, a sign of relief in this dark area.
2. I do have PPBUS_G3HPP3V42_G3H, so this explains the green light on the charger, a sign of relief in this dark area.
 
3. I'm afraid that the TPS51125, at this point, is dead. I'll test more heavily in the upcoming weeks before ordering a pack of them.
 
Long story short: it seems that, whoever tried to fix this board, removed ISL6259 and couldn't solder it back. It was a really messy board when I got it, with even a wire remaining on a solder pad. I'll return to post result in the upcoming weeks.
 
To determine what you need for your board, the best idea is head to [https://www.youtube.com/channel/UCl2mFZoRqjw_ELax4Yisf6w|Louis Rossmann's channel] and watch tons of his videos of the same subject. This allowed me to have a closer look into the state of my board and how I could fix it.

デバイス:

MacBook Pro 13" Unibody Early 2011

ステータス:

open

編集者: Lucas Silva ,

タイトル:

Dead MacBook Pro with flashing battery indicator

テキスト:

So I have a MacBook Pro, unibody, early 2011.
 
The machine doesn't boot up, it just lights the battery indicator five times when pressing the battery indicator button. After some presses, only one light appears to blink (five times again) and then suddenly stops responding.
 
The battery indicator lights are only seen with the MagSafe connected. And the MagSafe light stays green forever. (went orange one time and then returned to green). Without MagSafe, it's 100% dead.
 
Tried to heat the board, no success. MagSafe charger is 85W, so no problems with lower chargers.
 
Any ideas on how to solve this issue?
 
Thanks in advance.
 
EDIT: the machine doesn't boot up even without the battery (MagSafe only).
EDIT: the machine doesn't boot up even without the battery (MagSafe only).
 
=== Update (11/03/2017) ===
 
PS #1 - Nov 3rd
 
So I just got a 60W charger (aftermarket) to test with this MacBook Pro.
 
The results are "better", on par to what I expected. The machine still doesn't boot, with or without the battery (MagSafe only). However, the 60W MagSafe appears to fix the "death" of the battery indicator lights (finally).
 
So it starts with a blinking LED for a few seconds, and then "upgrade" to the full LED blinking five times. I didn't receive the battery yet - maybe next week.
So it starts with a blinking LED for a few seconds, and then "upgrade" to the full LED blinking five times. I didn't receive the battery yet - maybe next week.
 
Q: MacBooks are able to power on ONLY with the MagSafe power?

=== Update (04/22/2018) ===
Months after my initial question, I decided to take a very deep and closer look on the board to see if I was missing something. Turns out I'm really missing some important topics:

1. The A1278 schematics shows that the ISL6259 is probably the culprit of unbootable MacBook Pro boards. Problem is, my board is MISSING ISL6259 (AKA U7000), so this explains why it doesn't work at all. AFAIK, someone removed the chip and tried to solder it again, but failed miserably. I've already ordered some chips (pack of 5) and I'll let you guys know what happened.

2. I do have PPBUS_G3H, so this explains the green light on the charger, a sign of relief in this dark area.

3. I'm afraid that the TPS51125, at this point, is dead. I'll test more heavily in the upcoming weeks before ordering a pack of them.

Long story short: it seems that, whoever tried to fix this board, removed ISL6259 and couldn't solder it back. It was a really messy board when I got it, with even a wire remaining on a solder pad. I'll return to post result in the upcoming weeks.
To determine what you need for your board, the best idea is head to [https://www.youtube.com/channel/UCl2mFZoRqjw_ELax4Yisf6w|Louis Rossmann's channel] and watch tons of his videos of the same subject. This allowed me to have a closer look into the state of my board and how I could fix it.
Q: MacBooks are able to power on ONLY with the MagSafe power?

=== Update (04/22/2018) ===
Months after my initial question, I decided to take a very deep and closer look on the board to see if I was missing something. Turns out I'm really missing some important topics:

1. The A1278 schematics shows that the ISL6259 is probably the culprit of unbootable MacBook Pro boards. Problem is, my board is MISSING ISL6259 (AKA U7000), so this explains why it doesn't work at all. AFAIK, someone removed the chip and tried to solder it again, but failed miserably. I've already ordered some chips (pack of 5) and I'll let you guys know what happened.

2. I do have PPBUS_G3H, so this explains the green light on the charger, a sign of relief in this dark area.

3. I'm afraid that the TPS51125, at this point, is dead. I'll test more heavily in the upcoming weeks before ordering a pack of them.

Long story short: it seems that, whoever tried to fix this board, removed ISL6259 and couldn't solder it back. It was a really messy board when I got it, with even a wire remaining on a solder pad. I'll return to post result in the upcoming weeks.
To determine what you need for your board, the best idea is head to [https://www.youtube.com/channel/UCl2mFZoRqjw_ELax4Yisf6w|Louis Rossmann's channel] and watch tons of his videos of the same subject. This allowed me to have a closer look into the state of my board and how I could fix it.

デバイス:

MacBook Pro 13" Unibody Early 2011

ステータス:

open

編集者: Lucas Silva ,

タイトル:

Dead MacBook Pro with flashing battery indicator

テキスト:

So I have a MacBook Pro, unibody, early 2011.
 
The machine doesn't boot up, it just lights the battery indicator five times when pressing the battery indicator button. After some presses, only one light appears to blink (five times again) and then suddenly stops responding.
 
The battery indicator lights are only seen with the MagSafe connected. And the MagSafe light stays green forever. (went orange one time and then returned to green). Without MagSafe, it's 100% dead.
 
Tried to heat the board, no success. MagSafe charger is 85W, so no problems with lower chargers.
 
Any ideas on how to solve this issue?
 
Thanks in advance.
Thanks in advance.
 
EDIT: the machine doesn't boot up even without the battery (MagSafe only).

=== Update (11/03/2017) ===

PS #1 - Nov 3rd

So I just got a 60W charger (aftermarket) to test with this MacBook Pro.

The results are "better", on par to what I expected. The machine still doesn't boot, with or without the battery (MagSafe only). However, the 60W MagSafe appears to fix the "death" of the battery indicator lights (finally).

So it starts with a blinking LED for a few seconds, and then "upgrade" to the full LED blinking five times. I didn't receive the battery yet - maybe next week.

Q: MacBooks are able to power on ONLY with the MagSafe power?
EDIT: the machine doesn't boot up even without the battery (MagSafe only).

=== Update (11/03/2017) ===

PS #1 - Nov 3rd

So I just got a 60W charger (aftermarket) to test with this MacBook Pro.

The results are "better", on par to what I expected. The machine still doesn't boot, with or without the battery (MagSafe only). However, the 60W MagSafe appears to fix the "death" of the battery indicator lights (finally).

So it starts with a blinking LED for a few seconds, and then "upgrade" to the full LED blinking five times. I didn't receive the battery yet - maybe next week.

Q: MacBooks are able to power on ONLY with the MagSafe power?

デバイス:

MacBook Pro 13" Unibody Early 2011

ステータス:

open

編集者: Lucas Silva ,

タイトル:

Dead MacBook Pro with flashing battery indicator

テキスト:

So I have a MacBook Pro, unibody, early 2011.
 
The machine doesn't boot up, it just lights the battery indicator five times when pressing the battery indicator button. After some presses, only one light appears to blink (five times again) and then suddenly stops responding.
 
The battery indicator lights are only seen with the MagSafe connected. And the MagSafe light stays green forever. (went orange one time and then returned to green). Without MagSafe, it's 100% dead.
 
Tried to heat the board, no success. MagSafe charger is 85W, so no problems with lower chargers.
 
Any ideas on how to solve this issue?
 
Thanks in advance.

EDIT: the machine doesn't boot up even without the battery (MagSafe only).
Thanks in advance.

EDIT: the machine doesn't boot up even without the battery (MagSafe only).

デバイス:

MacBook Pro 13" Unibody Early 2011

ステータス:

open

オリジナル投稿者: Lucas Silva ,

タイトル:

Dead MacBook Pro with flashing battery indicator

テキスト:

So I have a MacBook Pro, unibody, early 2011.

The machine doesn't boot up, it just lights the battery indicator five times when pressing the battery indicator button. After some presses, only one light appears to blink (five times again) and then suddenly stops responding.

The battery indicator lights are only seen with the MagSafe connected. And the MagSafe light stays green forever. (went orange one time and then returned to green). Without MagSafe, it's 100% dead.

Tried to heat the board, no success. MagSafe charger is 85W, so no problems with lower chargers.

Any ideas on how to solve this issue?

Thanks in advance.

デバイス:

MacBook Pro 13" Unibody Early 2011

ステータス:

open