メインコンテンツにスキップ
ヘルプ

現在のバージョン作成者: unsubstantiated and oldturkey03 (投票の詳細) ,

タイトル:

iPhone 4S display black and constant vibrating (sounds) when charging?

テキスト:

I was repairing an iPhone 4S for someone and all went well. I reassembled it and turned it on, but the screen was black. At first I thought the battery was flat, but the phone was on and working (the CPU warmed up etc. etc.) I plugged it into my computer and it makes the sound that any iOS7.x.x makes when you start charging it. Thing is it makes this sound every 10 seconds or so as if i'm plugging and unplugging it. The screen is still black all through this. I assumed that the LCD was dead. (at this point I'd tried cleaning the connections, reseating the connections, blowing the phone out with an air canister, restarting the phone, resetting the phone. (I haven't restored it as it's not mine and refuse to do it without permission for obvious reasons). None of this has worked. I gave up and fixed a few more things by this point the battery had ran dead and I plugged in a new 4S screen that I had lying around. I held down the lock button and it worked, the phone showed the "needed charging" icon so I plugged it in and let it charge for 30 minutes. I came back and all was working well, so I unplugged that screen and plugged in the installed one, and truth be told the screen was black again. I plugged in the other screen and it was black too. I tried 2 more (cracked but working) screens and they were black also. I replaced the battery and it was still black. If it was a faulty LCD why would it not work with the other screens? If it was a damaged motherboard why would it work, not work, work, then not work again? I'm baffled. It's also recognised in iTunes, but has a password (which I have, but I don't know exactly what I'm pressing so unlocking it is a pain)! Any help would be greatly appreciated as this is the first time it's happened and i've fixed probably 40 iPhone 4S's. Thanks in advance! :)

デバイス:

iPhone 4S

ステータス:

open

アンサーフォーラムの回答が承認:

+205004

編集者: oldturkey03 ,

タイトル:

iPhone 4S display black and constant vibrating (sounds) when charging?

テキスト:

-I was repairing an iPhone 4S for someone and all went well. I reassembled it and turned it on, but the screen was black. At first I thought the battery was flat, but the phone was on and working (the CPU warmed up etc. etc.) I plugged it into my computer and it makes the sound that any iOS7.x.x makes when you start charging it. Thing is it makes this sound every 10 seconds or so as if i'm plugging and unplugging it. The screen is still black all through this. I assumed that the LCD was dead. (at this point I'd tried cleaning the connections, reseating the connections, blowing the phone out with an air canister, restarting the phone, resetting the phone. (I haven't restored it as it's not mine and refuse to do it without permission for obvious reasons). None of this has worked. I gave up and fixed a few more things by this point the battery had ran dead and I plugged in a new 4S screen that I had lying around. I held down the lock button and it worked, the phone showed the "needed charging" icon so I plugged it in and let it charge for 30 minutes. I came back and all was working well, so I unplugged that screen and plugged in the installed one, and truth be told the !@#$ screen was black again. I plugged in the other screen and it was black too. I tried 2 more (cracked but working) screens and they were black also. I replaced the battery and it was still black. If it was a faulty LCD why would it not work with the other screens? If it was a damaged motherboard why would it work, not work, work, then not work again? I'm baffled. It's also recognised in iTunes, but has a password (which I have, but I don't know exactly what I'm pressing so unlocking it is a pain)! Any help would be greatly appreciated as this is the first time it's happened and i've fixed probably 40 iPhone 4S's. Thanks in advance! :)
+I was repairing an iPhone 4S for someone and all went well. I reassembled it and turned it on, but the screen was black. At first I thought the battery was flat, but the phone was on and working (the CPU warmed up etc. etc.) I plugged it into my computer and it makes the sound that any iOS7.x.x makes when you start charging it. Thing is it makes this sound every 10 seconds or so as if i'm plugging and unplugging it. The screen is still black all through this. I assumed that the LCD was dead. (at this point I'd tried cleaning the connections, reseating the connections, blowing the phone out with an air canister, restarting the phone, resetting the phone. (I haven't restored it as it's not mine and refuse to do it without permission for obvious reasons). None of this has worked. I gave up and fixed a few more things by this point the battery had ran dead and I plugged in a new 4S screen that I had lying around. I held down the lock button and it worked, the phone showed the "needed charging" icon so I plugged it in and let it charge for 30 minutes. I came back and all was working well, so I unplugged that screen and plugged in the installed one, and truth be told the screen was black again. I plugged in the other screen and it was black too. I tried 2 more (cracked but working) screens and they were black also. I replaced the battery and it was still black. If it was a faulty LCD why would it not work with the other screens? If it was a damaged motherboard why would it work, not work, work, then not work again? I'm baffled. It's also recognised in iTunes, but has a password (which I have, but I don't know exactly what I'm pressing so unlocking it is a pain)! Any help would be greatly appreciated as this is the first time it's happened and i've fixed probably 40 iPhone 4S's. Thanks in advance! :)

デバイス:

iPhone 4S

ステータス:

open

オリジナル投稿者: fnqirepair ,

タイトル:

iPhone 4S display black and constant vibrating (sounds) when charging?

テキスト:

I was repairing an iPhone 4S for someone and all went well. I reassembled it and turned it on, but the screen was black. At first I thought the battery was flat, but the phone was on and working (the CPU warmed up etc. etc.) I plugged it into my computer and it makes the sound that any iOS7.x.x makes when you start charging it. Thing is it makes this sound every 10 seconds or so as if i'm plugging and unplugging it. The screen is still black all through this. I assumed that the LCD was dead. (at this point I'd tried cleaning the connections, reseating the connections, blowing the phone out with an air canister, restarting the phone, resetting the phone. (I haven't restored it as it's not mine and refuse to do it without permission for obvious reasons). None of this has worked. I gave up and fixed a few more things by this point the battery had ran dead and I plugged in a new 4S screen that I had lying around. I held down the lock button and it worked, the phone showed the "needed charging" icon so I plugged it in and let it charge for 30 minutes. I came back and all was working well, so I unplugged that screen and plugged in the installed one, and truth be told the !@#$ screen was black again. I plugged in the other screen and it was black too. I tried 2 more (cracked but working) screens and they were black also. I replaced the battery and it was still black. If it was a faulty LCD why would it not work with the other screens? If it was a damaged motherboard why would it work, not work, work, then not work again? I'm baffled. It's also recognised in iTunes, but has a password (which I have, but I don't know exactly what I'm pressing so unlocking it is a pain)! Any help would be greatly appreciated as this is the first time it's happened and i've fixed probably 40 iPhone 4S's. Thanks in advance! :)

デバイス:

iPhone 4S

ステータス:

open